acwing-785. 快速排序

本文最后更新于:2022年7月25日 上午

给定你一个长度为 n 的整数数列。

请你使用快速排序对这个数列按照从小到大进行排序

并将排好序的数列按顺序输出。

输入格式
输入共两行,第一行包含整数 n。

第二行包含 n 个整数(所有整数均在 $1∼10^9$ 范围内),表示整个数列。

输出格式
输出共一行,包含 n 个整数,表示排好序的数列。

数据范围
1≤n≤100000

输入样例:
5
3 1 2 4 5
输出样例:
1 2 3 4 5

2022 7 25二刷

需要注意的:
1、递归返回条件;
2、do while 的条件;
3、if的条件;
4、递归的参数

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
class Solution {
public:
void quick_sort(vector<int>& nums, int l, int r)
{
if (l >= r) return; // 递归返回条件,只剩一个元素就有序了,直接返回

int i = l - 1, j = r + 1, x = nums[l+r>>1];

while (i < j)
{
do i++; while (nums[i] < x);
do j--; while (nums[j] > x);
if (i < j) swap(nums[i], nums[j]);
}

quick_sort(nums, l, j);
quick_sort(nums, j+1, r);
}

vector<int> sortArray(vector<int>& nums) {
// 快速排序
quick_sort(nums, 0, nums.size()-1);
return nums;
}
};

快排模板quick_sort,熟记

注意:
do i++; while(q[i] < x); // **从小到大排序,左边都是 <= x的**
do j--; while(q[j] > x); // 从小到大排序,右边都是 >= x的

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include<iostream>
using namespace std;

const int N = 100010;

int q[N];

void quick_sort(int q[], int l, int r)
{
//递归的终止情况
if(l >= r) return;
//第一步:分成子问题
int i = l - 1, j = r + 1, x = q[l + r >> 1];
while(i < j)
{
do i++; while(q[i] < x); // 从小到大排序,左边都是 <= x的
do j--; while(q[j] > x); // 从小到大排序,右边都是 >= x的
if(i < j) swap(q[i], q[j]);
}
//第二步:递归处理子问题
quick_sort(q, l, j), quick_sort(q, j + 1, r);
//第三步:子问题合并.快排这一步不需要操作,但归并排序的核心在这一步骤
}

int main()
{
int n;
cin >> n;
for (int i = 0; i < n; i++) scanf("%d", &q[i]);

quick_sort(q, 0, n-1);

for (int i = 0; i < n; i++) cout << q[i] << " ";
return 0;
}